The issue has been resolved by Microsoft, European hubs should be fully accessible. You might experience slightly slower load times while the Microsoft services are fully recovering.
Posted Oct 09, 2025 - 10:14 EDT
Identified
The issue is due to a problem with Microsoft Azure infrastructure. Microsoft is actively working on a resolution.
Posted Oct 09, 2025 - 08:47 EDT
Investigating
There can be intermittent issues when loading pages (page not loading or slow to load) such as the project list in a European hub.