Service disruption in US region
Incident Report for BIM Track
Resolved
Microsoft has resolved the issue affecting their US datacenter, all services are now operational.
Posted Jan 10, 2025 - 18:43 EST
Identified
Hubs in the US region are currently affected by a Microsoft outage. The following activity centers might be temporarily slow or unaccessible:
- File Management
- Document Control
- Share Center
Posted Jan 10, 2025 - 10:25 EST
This incident affected: Web Application.