Intermittent issues with submittals, RFIs and change management

Incident Report for Newforma Konekt

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 06:20 EDT

Identified

The issue has been identified and a fix is currently being worked on.
Posted Oct 20, 2025 - 15:33 EDT

Investigating

An issue currently affects some functionalities in submittals, RFIs and contract change management activity centers. Some action buttons may not display or take slower than usual to show.
Posted Oct 20, 2025 - 15:30 EDT
This incident affected: Web Application.